Divizorii proprii ai unui numar

Se citeşte un număr întreg a. Să se realizeze in pseudocod un algoritm care să afişeze toti divizorii proprii ai numărului a.

 

t ← 0 

citeşte a

pentru i ← 2, [a/2] execută

 dacă (a % i = 0) atunci

 scrie i

 t ← 1 

 sf.daca

sf.pentru

daca t = 0 atunci

scrie „nu există divizori proprii"

sf.daca