Descompunerea în factori primi ai unui numar

Se citeşte un număr întreg a. Să se realizeze in pseudocod un algoritm care să afişeze factorii primi şi puterile lor pentru numărul citit.

 

citeşte a

d ← 2 

cat timp a > 1 execută

 p ← 0 

 cat timp (a % d = 0) execută 

 p ← p + 1

 a ← a / d

sf.cat timp

 dacă p ≠ 0 atunci

 scrie d "la puterea" p "*"

sf.daca

 d ← d + 1

sf.cat timp