Numere prietene

Se citesc două numere întregi a şi b. Să se realizeze in pseudocod un algoritm care să verifice dacă cele doau numere sunt prietene. Spunem ca două numere sunt prietene dacă suma divizorilor proprii ai unui număr este egală cu celalalt şi invers.

citeşte a, b

sa ← 0

sb ← 0

pentru i ← 2, [a/2] execută

| dacă (a % i = 0) atunci

| |  sa ← sa + i 

| |▄

|▄

pentru i ← 2, [b/2] execută

| dacă (b % i = 0) atunci

| |  sb ← sb + i 

| |▄

|▄

daca sa = b şi sb = a atunci 

| scrie „numere prietene”

| altfel

|   scrie „NU sunt numere prietene”

|▄