Oglinditul unui numar

Se citeşte un număr întreg a. Să se realizeze in pseudocod un algoritm care să afiseze oglinditul sau. Numim număr invers (sau oglindit) numărul format cu cifrele citite de la dreapta la stanga.

De exemplu dacă se citeşte pentru a valoarea 125 atunci algoritmul va afişa numărul invers 521

citeşte a

o ← 0 

cât timp a ≠ 0 execută

| o← o * 10 + a % 10

| a ← a / 10

|▄

scrie o