Palindrom

Se citeşte un număr întreg a. Să se realizeze in pseudocod un algoritm care să verifice dacă numărul citit este sau nu palindrom. Numim palindrom un număr care este egal cu oglinditul său.

De exemplu dacă se citeşte pentru a valoarea 121 atunci algoritmul va afişa „este palindrom", iar dacă va citi 122 va afişa „nu este palindrom".

 

citeşte a

aux ← a

o ← 0

cât timp aux ≠ 0 execută

| o ← o * 10 + aux % 10

| aux ← aux / 10

|▄

Dacă a = o atunci

| scrie „este palindrom"

|altfel

| scrie „nu este palindrom"

|▄